You are here: Home » Справка и подсказки » Решение проблемы «ломает зависимость ‘perl<5.25'»

Решение проблемы «ломает зависимость ‘perl<5.25'»

Если при попытке обновить систему вы сталкиваетесь с ошибкой:

разрешение зависимостей...
проверка конфликтов...
ошибка: не удалось подготовить транзакцию (не удалось удовлетворить зависимости)
:: gnome-perl: установка perl (5.26.0-1) ломает зависимость 'perl<5.25'
:: gnome-vfs-perl: установка perl (5.26.0-1) ломает зависимость 'perl<5.25'
:: gnomecanvas-perl: установка perl (5.26.0-1) ломает зависимость 'perl<5.25'
:: perl-gnome2-wnck: установка perl (5.26.0-1) ломает зависимость 'perl<5.25'
:: perl-goo-canvas: установка perl (5.26.0-1) ломает зависимость 'perl<5.25'
:: perl-gtk2-imageview: установка perl (5.26.0-1) ломает зависимость 'perl<5.25'
:: perl-gtk2-unique: установка perl (5.26.0-1) ломает зависимость 'perl<5.25'

Она означает, что у вас установлена программа для захвата скриншотов Shutter и некоторые из её многочисленных зависимостей препятствуют обновлению.

Поскольку программа Shutter не обновлялась уже три года, то вряд ли удастся дождаться новой версии, в которой эта проблема будет исправлена. По этой причине, возможно, стоит удалить shutter и её зависимости и выбрать альтернативную программу для захвата скриншотов в Linux.

Чтобы удалить shutter и мешающие зависимости выполните:

sudo pacman -R shutter perl-gtk2-unique perl-gtk2-imageview perl-goo-canvas perl-gnome2-wnck gnomecanvas-perl gnome-vfs-perl gnome-perl

После этого снова запустите обновление – ошибки, связанные с зависимостями 'perl<5.25', должны пропасть.

1 Comment

  1. Благодарю, помогло!

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *